Summer Certification Sale 70% Discount Offer - Ends in 0d 00h 00m 00s - Coupon code: clap70

SPLK-1002 Splunk Core Certified Power User Exam Questions and Answers

Questions 4

A Splunk app is configured to extract domain names in web service logs and specify them as a field named domain.

What workflow action would return an external IP lookup for the field named domain?

Options:

A.

POST

B.

PUT

C.

GET

D.

Search

Buy Now
Questions 5

Which of the following statements are true for this search? (Select all that apply.) SEARCH: sourcetype=access* |fields action productld status

Options:

A.

is looking for all events that include the search terms: fields AND action AND productld AND status

B.

users the table command to improve performance

C.

limits the fields are extracted

D.

returns a table with 3 columns

Buy Now
Questions 6

What fields does the transaction command add to the raw events? (select all that apply)

Options:

A.

count

B.

duration

C.

eventcount

D.

transaction id

Buy Now
Questions 7

When using the transaction command, what is the assigned timestamp for each of the resulting transactions?

Options:

A.

The timestamp of the event search time execution.

B.

The timestamp of the earliest event.

C.

The difference between the earliest and latest event.

D.

The timestamp of the most recent event.

Buy Now
Questions 8

For the following search, which command would further filter for only IP addresses present more than five times?

Options:

A.

index=games I stats count as IP_count by IP B. | where IP_count > 5

B.

index=games | search IP_Count > 5

C.

index=games | where IP > 5

D.

index=games I search IP > 5

Buy Now
Questions 9

Which of the following statements would help a user choose between the transaction and stats commands?

Options:

A.

state can only group events using IP addresses.

B.

The transaction command is faster and more efficient.

C.

There is a 1000 event limitation with the transaction command.

D.

Use state when the events need to be viewed as a single event.

Buy Now
Questions 10

The Common Information Model (CIM) Add-on contains a collection of what preconfigured knowledge objects?

Options:

A.

Reports

B.

Data models

C.

Field extractions

D.

Dashboards

Buy Now
Questions 11

A POST workflow action will pass which types of arguments to an external website?

Options:

A.

Clear text only.

B.

A mix of clear text strings and variables.

C.

It can only send raw event data.

D.

Variables only.

Buy Now
Questions 12

Which of the following statements best describes the search string below?

| datamodel Application_State search

Options:

A.

Events will be returned from dataset Application_State.

B.

Events will be returned from the data model named Application_State.

C.

No events will be returned; the pipe must occur after the data model command.

D.

Events will be returned from the data model named Application_State (flat mode).

Buy Now
Questions 13

After manually editing; a regular expression (regex), which of the following statements is true?

Options:

A.

Changes made manually can be reverted in the Field Extractor (FX) UI.

B.

It is no longer possible to edit the field extraction in the Field Extractor (FX) UI.

C.

It is not possible to manually edit a regular expression (regex) that was created using the Field Extractor (FX) UI.

D.

The Field Extractor (FX) UI keeps its own version of the field extraction in addition to the one that was manually edited.

Buy Now
Questions 14

What information must be included when using the datamodel command?

Options:

A.

status field

B.

Multiple indexes

C.

Data model field name.

D.

Data model dataset name.

Buy Now
Questions 15

What field must be present in order to use the timechart command?

Options:

A.

_raw

B.

rime

C.

_time

D.

index

Buy Now
Questions 16

When creating an event type, which is allowed in the search string?

Options:

A.

Tags

B.

Joins

C.

Subsearches

D.

Pipes

Buy Now
Questions 17

When multiple event types with different color values are assigned to the same event, what determines the color displayed for the events?

Options:

A.

Rank

B.

Weight

C.

Priority

D.

Precedence

Buy Now
Questions 18

When using the timechart command, how can a user group the events into buckets based on time?

Options:

A.

Using the span argument.

B.

Using the duration argument.

C.

Using the interval argument.

D.

Adjusting the fieldformat options.

Buy Now
Questions 19

This function of the stats command allows you to return the middle-most value of field X.

Options:

A.

Median(X)

B.

Eval by X

C.

Fields(X)

D.

Values(X)

Buy Now
Questions 20

Which of the following statements describes an event type?

Options:

A.

A log level measurement: info, warn, error.

B.

A knowledge object that is applied before fields are extracted.

C.

A field for categorizing events based on a search string.

D.

Either a log, a metric, or a trace.

Buy Now
Questions 21

By default, how is acceleration configured in the Splunk Common Information Model (CIM) add-on?

Options:

A.

Turned off

B.

Turned on

C.

Determined automatically based on the sourcetype.

D.

Determined automatically based on the data source.

Buy Now
Questions 22

What commands can be used to group events from one or more data sources?

Options:

A.

eval, coalesce

B.

transaction, stats

C.

stats, format

D.

top, rare

Buy Now
Questions 23

Which of the following search control will not re-rerun the search? (Select all that apply.)

Options:

A.

zoom out

B.

selecting a bar on the timeline

C.

deselect

D.

selecting a range of bars on the timelines

Buy Now
Questions 24

Which delimiters can the Field Extractor (FX) detect? (select all that apply)

Options:

A.

Tabs

B.

Pipes

C.

Spaces

D.

Commas

Buy Now
Questions 25

What are the names of the top-level datasets in data models?

Options:

A.

Core datasets

B.

Root datasets

C.

Root indexes

D.

Core indexes

Buy Now
Questions 26

What is the correct Boolean order of evaluation for the where command from first to last?

Options:

A.

NOT, Parentheses, OR, AND

B.

AND, Parentheses, NOT, OR

C.

Parentheses, NOT, AND, OR

D.

Parentheses, NOT, OR, AND

Buy Now
Questions 27

Tags can reference which of the following knowledge objects?

Options:

A.

Lookups and event types only.

B.

Extracted fields, field aliases, calculated fields, lookups, and event types.

C.

Tags cannot reference any of these knowledge objects because tags are the last knowledge objects generated in the search-time operation sequence.

D.

Extracted fields, calculated fields, and field aliases only.

Buy Now
Questions 28

Which of the following statements about tags is true? (select all that apply.)

Options:

A.

Tags are case-insensitive.

B.

Tags are based on field/vale pairs.

C.

Tags categorize events based on a search.

D.

Tags are designed to make data more understandable.

Buy Now
Questions 29

What is needed to define a calculated field?

Options:

A.

Eval expression

B.

Data model

C.

Event type

D.

Regular expression

Buy Now
Questions 30

Which of the following search modes automatically returns all extracted fields in the fields sidebar?

Options:

A.

Fast

B.

Smart 

C.

C. Verbose

Buy Now
Questions 31

Which of the following statements describe the search below? (select all that apply)

Index=main I transaction clientip host maxspan=30s maxpause=5s

Options:

A.

Events in the transaction occurred within 5 seconds.

B.

It groups events that share the same clientip and host.

C.

The first and last events are no more than 5 seconds apart.

D.

The first and last events are no more than 30 seconds apart.

Buy Now
Questions 32

Which of the following statements describes the use of the Filed Extractor (FX)?

Options:

A.

The Field Extractor automatically extracts all field at search time.

B.

The Field Extractor uses PERL to extract field from the raw events.

C.

Field extracted using the Extracted persist as knowledge objects.

D.

Fields extracted using the Field Extractor do not persist and must be defined for each search.

Buy Now
Questions 33

What approach is recommended when using the Splunk Common Information Model (CIM) add-on to normalize data?

Options:

A.

Consult the CIM data model reference tables.

B.

Run a search using the authentication command.

C.

Consult the CIM event type reference tables.

D.

Run a search using the correlation command.

Buy Now
Questions 34

Which of the following searches would create a graph similar to the one below?

Options:

A.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | start count states

B.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | chart count states by -time

C.

index_internal seourcetype=Savesplunker | fields sourcetype, status | transaction status maxspan-id | timechart count by status

D.

None of these searches would generate a similart graph.

Buy Now
Questions 35

Which of the following fields should be normalized using the Splunk Common Information Model (CIM) based on their relationship?

Options:

A.

src_ip, dest_ip

B.

src_ip, source_ip

C.

index, sourcetype

D.

src_ip, src_port

Buy Now
Questions 36

When should you use the transaction command instead of the scats command?

Options:

A.

When you need to group on multiple values.

B.

When duration is irrelevant in search results. .

C.

When you have over 1000 events in a transaction.

D.

When you need to group based on start and end constraints.

Buy Now
Questions 37

In this search, __________ will appear on the y-axis. SEARCH: sourcetype=access_combined status!=200 | chart count over host

Options:

A.

status

B.

host

C.

count

Buy Now
Questions 38

The timechart command is an example of which of the following command types?

Options:

A.

Orchestrating

B.

Transforming

C.

Statistical

D.

Generating

Buy Now
Questions 39

Which of the following searches show a valid use of a macro? (Choose all that apply.)

Options:

A.

index=main source=mySource oldField=* |’makeMyField(oldField)’| table _time newField

B.

index=main source=mySource oldField=* | stats if(‘makeMyField(oldField)’) | table _time newField

C.

index=main source=mySource oldField=* | eval newField=’makeMyField(oldField)’| table _time newField

D.

index=main source=mySource oldField=* | "’newField(‘makeMyField(oldField)’)’" | table _time newField

Buy Now
Questions 40

When using | timchart by host, which filed is representted in the x-axis?

Options:

A.

date

B.

host

C.

time

D.

-time

Buy Now
Questions 41

Which of the following searches would return a report of sales by product-name?

Options:

A.

chart sales by product_name

B.

chart sum(price) as sales by product_name

C.

stats sum(price) as sales over product_name

D.

timechart list(sales), values(product_name)

Buy Now
Questions 42

When creating a search workflow action, what character(s) are used as a placeholder for field values in the search string?

Options:

A.

*

B.

()

C.

$

D.

#

Buy Now
Questions 43

The eval command 'if' function requires the following three arguments (in order):

Options:

A.

Boolean expression, result if true, result if false

B.

Result if true, result if false, boolean expression

C.

Result if false, result if true, boolean expression

D.

Boolean expression, result if false, result if true

Buy Now
Questions 44

What other syntax will produce exactly the same results as | chart count over vendor_action by user?

Options:

A.

| chart count by vendor_action, user

B.

| chart count over vendor_action, user

C.

| chart count by vendor_action over user

D.

| chart count over user by vendor_action

Buy Now
Questions 45

What do events in a transaction have In common?

Options:

A.

All events In a transaction must have the same timestamp.

B.

All events in a transaction must have the same sourcetype.

C.

All events in a transaction must have the exact same set of fields.

D.

All events in a transaction must be related by one or more fields.

Buy Now
Questions 46

When a search returns __________, you can view the results as a list.

Options:

A.

a list of events

B.

transactions

C.

statistical values

Buy Now
Questions 47

Which of the following statements about calculated fields in Splunk is true?

Options:

A.

Calculated fields cannot be chained together to create more complex fields

B.

Calculated fields can be chained together to create more complex fields.

C.

Calculated fields can only be used in dashboards.

D.

Calculated fields can only be used in saved reports.

Buy Now
Questions 48

In the following eval statement, what is the value of description if the status is 503? index=main | eval description=case(status==200, "OK", status==404, "Not found", status==500, "Internal Server Error")

Options:

A.

The description field would contain no value.

B.

The description field would contain the value 0.

C.

The description field would contain the value "Internal Server Error".

D.

This statement would produce an error in Splunk because it is incomplete.

Buy Now
Questions 49

Highlighted search terms indicate _________ search results in Splunk.

Options:

A.

Display as selected fields.

B.

Sorted

C.

Charted based on time

D.

Matching

Buy Now
Questions 50

Which of the following commands connects an additional table of data directly to the right side of the existing table?

Options:

A.

subsearch

B.

update

C.

appendcols

D.

append

Buy Now
Questions 51

Which method in the Field Extractor would extract the port number from the following event? |

10/20/2022 - 125.24.20.1 ++++ port 54 - user: admin < web error >

Options:

A.

Delimiter

B.

rex command

C.

The Field Extractor tool cannot extract regular expressions.

D.

Regular expression

Buy Now
Questions 52

Which function should you use with the transaction command to set the maximum total time between the earliest and latest events returned?

Options:

A.

maxpause

B.

endswith

C.

maxduration

D.

maxspan

Buy Now
Questions 53

Which of the following data model are included In the Splunk Common Information Model (CIM) add-on? (select all that apply)

Options:

A.

Alerts

B.

Email

C.

Database

D.

User permissions

Buy Now
Questions 54

The limit attribute will___________.

Options:

A.

override default of 10

B.

only work with top command

C.

override default of 20

D.

override default of 15

Buy Now
Questions 55

The Field Extractor (FX) is used to extract a custom field. A report can be created using this custom field. The created report can then be shared with other people in the organization. If another person in the organization runs the shared report and no results are returned, why might this be? (select all that apply)

Options:

A.

Fast mode is enabled.

B.

The dashboard is private.

C.

The extraction is private-

D.

The person in the organization running the report does not have access to the index.

Buy Now
Questions 56

When should the regular expression mode of Field Extractor (FX) be used? (select all that apply)

Options:

A.

For data cleanly separated by a space, a comma, or a pipe character.

B.

For data in a CSV (comma-separated value) file.

C.

For data with multiple, different characters separating fields.

D.

For unstructured data.

Buy Now
Questions 57

When used with the timechart command, which value of the limit argument returns all values?

Options:

A.

limit=*

B.

limit=all

C.

limit=none

D.

limit=0

Buy Now
Questions 58

There are several ways to access the field extractor. Which option automatically identifies data type, source type, and sample event?

Options:

A.

Event Actions > Extract Fields

B.

Fields sidebar > Extract New Field

C.

Settings > Field Extractions > New Field Extraction

D.

Settings > Field Extractions > Open Field Extraction

Buy Now
Questions 59

Which of the following searches can be used to define an event type?

Options:

A.

index=games sourcetype=score [search index=players | fields player_id]

B.

index=games sourcetype=score I where score > 9999

C.

index=games sourcetype=score player=* score > 9999

D.

index=games sourcetype=score I stats count by player

Buy Now
Questions 60

When using timechart, how many fields can be listed after a by clause?

Options:

A.

because timechart doesn't support using a by clause.

B.

because _time is already implied as the x-axis.

C.

because one field would represent the x-axis and the other would represent the y-axis.

D.

There is no limit specific to timechart.

Buy Now
Questions 61

Which of the following statements about tags is true?

Options:

A.

Tags are case insensitive.

B.

Tags can make your data more understandable.

C.

Tags are created at index time.

D.

Tags are searched by using the syntax tag :: < fieldname > .

Buy Now
Questions 62

What does the Splunk Common Information Model (CIM) add-on include? (select all that apply)

Options:

A.

Custom visualizations

B.

Pre-configured data models

C.

Fields and event category tags

D.

Automatic data model acceleration

Buy Now
Questions 63

Two separate results tables are being combined using the |join command. The outer table has the following values:

Refer to following Tables

The line of SPL used to join the tables is: | join employeeNumber type=outer

How many rows are returned in the new table?

Options:

A.

Zero

B.

Five

C.

Eight

D.

Three

Buy Now
Questions 64

The timechart command buckets data in time intervals depending on:

Options:

A.

the number of events returned

B.

the selected time range

C.

the type of visualization selected

Buy Now
Questions 65

What is the correct syntax to search for a tag associated with a value on a specific fields?

Options:

A.

Tag- < field?

B.

Tag < filed(tagname.)

C.

Tag= < filed > :: < tagname >

D.

Tag:: < filed > = < tagname >

Buy Now
Questions 66

A user wants to create a new field alias for a field that appears in two sourcetypes.

How many field aliases need to be created?

Options:

A.

One.

B.

Two.

C.

It depends on whether the original fields have the same name.

D.

It depends on whether the two sourcetypes are associated with the same index.

Buy Now
Questions 67

Which search commands allow a user to access data model summaries?

Options:

A.

pivot, stats, and datamodel

B.

pivot, tstats, and datamodel

C.

transaction, tstats, and datamodel

D.

stats, tstats, and datamodel

Buy Now
Questions 68

Which of the following is included with the Common Information Model (CIM) add-on?

Options:

A.

Search macros

B.

Event category tags

C.

Workflow actions

D.

tsidx files

Buy Now
Questions 69

When using a field value variable with a Workflow Action, which punctuation mark will escape the data

Options:

A.

*

B.

!

C.

^

D.

#

Buy Now
Questions 70

Which of the following statements describes Search workflow actions?

Options:

A.

By default. Search workflow actions will run as a real-time search.

B.

Search workflow actions can be configured as scheduled searches,

C.

The user can define the time range of the search when created the workflow action.

D.

Search workflow actions cannot be configured with a search string that includes the transaction command

Buy Now
Questions 71

Which of the following searches can be saved as an event type?

Options:

A.

index=server_516 sourcetype=BETA_201 code=S51 [ | inputlookup servercode.csv append=t ]

B.

index=server_516 sourcetype=BETA_201 code=551

C.

index=server_516 sourcetype=BETA_201 code=551 | stats count by code

D.

index=server_516 sourcetype=BETA_201 code=551 | where code > 200

Buy Now
Questions 72

Which of the following statements describes this search?

sourcetype=access_combined I transaction JSESSIONID | timechart avg (duration)

Options:

A.

This is a valid search and will display a timechart of the average duration, of each transaction event.

B.

This is a valid search and will display a stats table showing the maximum pause among transactions.

C.

No results will be returned because the transaction command must include the startswith and endswith options.

D.

No results will be returned because the transaction command must be the last command used in the search pipeline.

Buy Now
Questions 73

What are the expected search results from executing the following SPL command?

index=network NOT StatusCode=200

Options:

A.

Every event in the network index that does not have a value in this field.

B.

Every event in the network index that does not contain a StatusCode of 200 and excluding events that do not have a value in this field.

C.

Every event in the network index that does not contain a StatusCode of 200, including events that do not have a value in this field.

D.

No results as the syntax is incorrect, the != field expression needs to be used instead of the NOT operator.

Buy Now
Questions 74

Why are tags useful in Splunk?

Options:

A.

Tags look for less specific data.

B.

Tags visualize data with graphs and charts.

C.

Tags group related data together.

D.

Tags add fields to the raw event data.

Buy Now
Questions 75

Given the event below, how can the value in the Zip_Code field be used to retrieve the local weather from an external resource?

25/Oct/2023:20:29:43 , 151.131.173.143 , V2.003 , Zip_Code: 75890 , DataCenter: DC1

Options:

A.

Create a POST workflow action.

B.

Create a GET workflow action.

C.

Create a PUT workflow action.

D.

Create a Search workflow action.

Buy Now
Questions 76

To identify all of the contributing events within a transaction that contains at least one REJECT event, which syntax is correct?

Options:

A.

Index-main | REJECT trans sessionid

B.

Index-main | transaction sessionid | search REJECT

C.

Index=main | transaction sessionid | whose transaction=reject

D.

Index=main | transaction sessionid | where transaction=reject’’

Buy Now
Questions 77

Which of the following statements best describes a macro?

Options:

A.

A macro is a method of categorizing events based on a search.

B.

A macro is a way to associate an additional (new) name with an existing field name.

C.

A macro is a portion of a search that can be reused in multiple place

D.

A macro is a knowledge object that enables you to schedule searches for specific events.

Buy Now
Questions 78

When using multiple expressions in a single eval command, which delimiter is used?

Options:

A.

, (comma)

B.

I (pipe)

C.

/ (forward slash)

D.

: (colon)

Buy Now
Questions 79

Which of the following Statements about macros is true? (select all that apply)

Options:

A.

Arguments are defined at execution time.

B.

Arguments are defined when the macro is created.

C.

Argument values are used to resolve the search string at execution time.

D.

Argument values are used to resolve the search string when the macro is created.

Buy Now
Questions 80

What does the fillnull command replace null values with, it the value argument is not specified?

Options:

A.

0

B.

N/A

C.

NaN

D.

NULL

Buy Now
Questions 81

Calculated fields can be based on which of the following?

Options:

A.

Tags

B.

Extracted fields

C.

Output fields for a lookup

D.

Fields generated from a search string

Buy Now
Questions 82

Which of the following is true about a datamodel that has been accelerated?

Options:

A.

They can be used with Pivot, the | tstats command, or the | datamodel command.

B.

They can still be used in the Pivot tool but only with the accelerate_pivot capability.

C.

They can no longer be used in the Pivot tool.

D.

They can be used with the |tstats command, but will only return that data which has been accelerated.

Buy Now
Questions 83

In most large Splunk environments, what is the most efficient command that can be used to group events by fields/

Options:

A.

join

B.

stats

C.

streamstats

D.

transaction

Buy Now
Questions 84

Which of the following is true about the Splunk Common Information Model (CIM)?

Options:

A.

The data models included in the CIM are configured with data model acceleration turned off.

B.

The CIM contains 28 pre-configured datasets.

C.

The CIM is an app that needs to run on the indexer.

D.

The data models included in the CIM are configured with data model acceleration turned on.

Buy Now
Questions 85

By default search results are not returned in ________ order.

Options:

A.

Chronological

B.

Reverser chronological

C.

ASCIE

D.

Alphabetical

Buy Now
Questions 86

The macro weekly_sales (2) contains the search string:

index=games | eval ProductSales = $Price$ * $AmountSold$

Which of the following will return results?

Options:

A.

‘weekly sales (3)’

B.

‘weekly_sales($3.995, $108)’

C.

'weekly_sales (3.99, 10)’

D.

‘weekly sales (3.99, 10)’

Buy Now
Questions 87

Which syntax is used to represent an argument in a macro definition?

Options:

A.

"argument"

B.

%argument%

C.

‘argument’

D.

$argument$

Buy Now
Questions 88

Data model fields can be added using the Auto-Extracted method. Which of the following statements describe Auto-Extracted fields? (select all that apply)

Options:

A.

Auto-Extracted fields can be hidden in Pivot.

B.

Auto-Extracted fields can have their data type changed.

C.

Auto-Extracted fields can be given a friendly name for use in Pivot.

D.

Auto-Extracted fields can be added if they already exist in the dataset with constraints.

Buy Now
Questions 89

The time range specified for a historical search defines the ____________ .------questionable on ans

Options:

A.

Amount of data shown on the timeline as data streams in

B.

Amount of data fetched from index matching that time range

C.

Time range for the static results

Buy Now
Questions 90

In which of the following scenarios is an event type more effective than a saved search?

Options:

A.

When a search should always include the same time range.

B.

When a search needs to be added to other users' dashboards.

C.

When the search string needs to be used in future searches.

D.

When formatting needs to be included with the search string.

Buy Now
Questions 91

A field alias is created where field1—fieid2 and the Overwrite Field Values checkbox is selected.

What happens if an event only contains values for fieid1?

Options:

A.

field2 values are removed from the events.

B.

field1 and field2 values are merged.

C.

field2 values are unchanged.

D.

field2 values are replaced with the value of the field1.

Buy Now
Questions 92

How is an event type created from the search window? (select all that apply)

Options:

A.

In the top right corner, click Save As > Event Type.

B.

In an event's detail dropdown, click Event Actions > Build Event Type.

C.

Edit eventtypes.conf and add a new stanza.

D.

Add | eventtype to the SPL and execute the search.

Buy Now
Questions 93

Consider the following search:

index=web sourcetype=access_corabined

The log shows several events that share the same jsesszonid value (SD462K101O2F267). View the events as a group.

From the following list, which search groups events by jSSESSIONID?

Options:

A.

index=web sourcetype=access_combined I transaction JSESSZONID I search SD462K101C2F267

B.

index=web sourcetype=access_combined SD462K101O2F267 | table JSESSIONID

C.

index=web sourcetype=access_combined | highlight JSESSIONID | search SD462K101O2F267

D.

index=web sourcetype=access_combined JSESSTONID < SD4€2K101O2F267 >

Buy Now
Exam Code: SPLK-1002
Exam Name: Splunk Core Certified Power User Exam
Last Update: Aug 15, 2026
Questions: 313
SPLK-1002 pdf

SPLK-1002 PDF

$25.5  $84.99
SPLK-1002 Engine

SPLK-1002 Testing Engine

$30  $99.99
SPLK-1002 PDF + Engine

SPLK-1002 PDF + Testing Engine

$40.5  $134.99